OpenWrt

Projekt OpenWrt mit TP-Link TL-MR3020 

direkter Aufruf (geht nur local): 192.168.2.79

Projektseite mr3020: http://wiki.openwrt.org/toh/tp-link/tl-mr3020

Projektseite mr703n: http://www.madox.net/blog/projects/tp-link-tl-wr703n/

NSLU2:   http://www.aprs4r.org/cgi-bin/trac.cgi/wiki/NSLU2OpenWrtInstallationGerman
http://wiki.openwrt.org/toh/linksys/nslu2

OpenWrt Basics:  --

busybox: http://busybox.net/downloads/BusyBox.html 

df (Anzeige freies Flash-Filesystem)
free (Anzeige freies RAM)
cat (Datei Inhalt (text)  anzeigen)
vi ( Befehle 'w:'= write, ':q' = quit)
logread (System-log-Datei anzeigen)
tail -f /var/log/lastlog (lastlog anzeigen, mit 'tail -f' auch alles andere)

Failsave:

- Blinkende WPS-Taste (blinkt langsam) drücken (blinkt schnell)
- Direkt an Ethernetbuchse des Rechner einstecken (und Ethernet im Rechner auf 192.168.1.2 einstellen)

telnet 192.168.1.1

mount_root
passwd ( Passwort eingeben - Hinweis auf zu kurz ignorieren)
firstboot (nur bei Bedarf)
reboot -f

- ausschalten -

Zugang auf Ethernet-Port:

ssh root@192.168.1.1

 Ethernet-Netzwerk für Internet-Zugang einstellen


- Hinweis: nur jeweils Ethernet oder WLAN mit der gleichen Subnet-Adresse belegen (z.b. 192.168.2.x)

siehe auch http://wiki.openwrt.org/doc/howto/internet.connection

Falls zunächst nur Ethernet-Zugang eingestellt werden soll:

uci set network.lan.ipaddr=192.168.2.80
uci set network.lan.dns=192.168.2.1
uci set network.lan.gateway=192.168.2.1

uci commit network ifup lan

-  auschalten
- LAN an Router LAN (z.B: Fritzbox) anstecken
- testen und neu verbinden

ping 192.168.2.80
ssh root@192.168.2.80
ping heise.de

LuCi Web-Configuration nachinstallieren

siehe auch: http://wiki.openwrt.org/doc/howto/luci.essentials

opkg update
opkg install luci
/etc/init.d/uhttpd enable /etc/init.d/uhttpd start

alles Andere:

siehe auch: http://wiki.openwrt.org/doc/recipes/start


Konfiguration für WLAN

Ethernet auf 192.168.2.1 (z.B. als Notfallport für Betrieb direkt am Rechner)

WLAN auf 192.168.2.79 (für DSL-Router auf 192.168.2.1): ssid, bssid, key durch eigene Daten ersetzten

Einstellung über UCI

uci set network.lan.ipaddr=192.168.1.1
uci set network.lan.dns=192.168.2.1
uci set network.lan.gateway=192.168.2.1

uci set network.wwan._orig_bridge=false
uci set network.wwan.proto=static
uci set network.wwan.ipaddr=192.168.2.79
uci set network.wwan.netmask=255.255.255.0
uci set network.wwan.gateway=192.168.2.1
uci set network.wwan.dns=192.168.2.1


uci set wireless.@wifi-iface[0]=wifi-iface
uci set wireless.@wifi-iface[0].network=wwan
uci set wireless.@wifi-iface[0].ssid=<myssid>
uci set wireless.@wifi-iface[0].encryption=psk2
uci set wireless.@wifi-iface[0].device=radio0
uci set wireless.@wifi-iface[0].mode=sta
uci set wireless.@wifi-iface[0].bssid=BC:05:43:EE:7A:CD
uci set wireless.@wifi-iface[0].key=<mykey>


uci commit network
uci commit wireless ifup wwan

Direkte Einstellung:

/etc/config/network:

config interface 'lan'
        option ifname 'eth0'
        option proto 'static'
        option netmask '255.255.255.0'
        option ipaddr '192.168.1.1'

config interface 'wwan'
        option _orig_ifname 'wlan0'
        option _orig_bridge 'false'
        option proto 'static'
        option ipaddr '192.168.2.79'
        option netmask '255.255.255.0'
        option gateway '192.168.2.1'
        option dns '192.168.2.1'

----------------------

/etc/config/dhcp:

config dnsmasq
        option domainneeded '1'
        option boguspriv '1'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option domain 'lan'
        option expandhosts '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.auto'
        option local '192.168.2.1'

config dhcp 'lan'
        option interface 'lan'
        option ignore '1'

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'

----------------------------

/etc/config/wireless:

config wifi-device 'radio0'
        option type 'mac80211'
        option macaddr 'f8:d1:11:bd:44:ce'
        option hwmode '11ng'
        option htmode 'HT20'
        list ht_capab 'SHORT-GI-20'
        list ht_capab 'SHORT-GI-40'
        list ht_capab 'RX-STBC1'
        list ht_capab 'DSSS_CCK-40'
        option disabled '0'
        option channel '3'
        option country 'DE'
        option txpower '20'

config wifi-iface
        option network 'wwan'
        option ssid '<MYSSIS>'
        option encryption 'psk2'
        option device 'radio0'
        option mode 'sta'
        option bssid 'xx:xx:xx:xx:xx:xx'
        option key '<mykey>'

------------------------------